Jump to content
Sign in to follow this  
Don Taylor

Concertina.net is preventing my Win 10 system from going to sleep

Recommended Posts

I have recently noticed that my Windows 10 computer no longer goes to sleep at night.  A bit of investigation reveals that it is my Firefox browser that is preventing sleep, more specifically it is an open tab for concertina.net that seems to be the culprit.

 

A couple of screen shots.

 

The first one shows my system with Firefox running and no concertina.net tab:

image.png.6edd22ae75f6f30c57b6ad6726da6123.png

and the computer will happily go to sleep.

 

When I open a tab with concertina.net, I get the following:

image.png.ccd9d5e051cccf0d748ea24bb60f5d35.png

Concertina.net has opened an audio stream which keeps my computer wake at night, but no audio is being played.

 

Can anything be done about this?

 

Thx.  Don.

 

Added:  Running an ad-blocker does not help so it appears to be the forum code that is requesting an audio stream.  And no, I do not normally run an ad-blocker against concertina.net.

Edited by Don Taylor

Share this post


Link to post
Share on other sites

Don, I've (silently) followed your advice on computing related matters in the past, and very useful it's been.

 

Thank you for the heads-up here.

 

To clarify, do you think the problem is caused by having concertina.net bookmarked in my browser(s) (I use

Chrome and Firefox with about equal frequency), or is it caused by leaving myself logged-in to concertina.net

on a 'permanent' basis?

 

Thank you.

 

Roger

 

PS: So far I've been unable to reproduce the dialogues you show in your screen-shots because I need administrator

privileges - which I do not seem to have, despite the fact that it's my machine...😕

Edited by lachenal74693

Share this post


Link to post
Share on other sites

I can confirm the powercfg results; a different "device" (HDAUDIO\FUNC_01&VEN_10EC&DEV_0288&SUBSYS_10EC0191&REV_1000\4&dcc60be&0&0001)
An audio stream is currently in use, but the same result. I don't Sleep, so can't verify that.

Share this post


Link to post
Share on other sites
15 hours ago, Pianist said:

The recommended solution seems to be to use :

powercfg -REQUESTSOVERRIDE DRIVER "High Definition Audio Device" SYSTEM

 

I am reluctant to try this as there seems to be no way to reverse this override should it go pear shaped (as it did for one responder in the thread).  I might give it a go after my next system backup which would allow me to recover if there are any problems.  Closing Firefox does enable sleep so that is what I will do for now

 

Roger:

 

As Pianist says, you need admin privileges to run powercfg.  Try [Windows key] + cmd then select run as administrator. 

Bookmarking concertina.net should not cause the problem, you need to have it open in a tab.  Don't know about Chrome as I do not have it installed.

 

Don.

Share this post


Link to post
Share on other sites

But why is concertina.net opening an audio stream in the first place.

I have hearing aids which are capable of receiving audio from my iPad using Bluetooth. When I open c.net the hearing aid stops listening to the outside world and tunes in to the audio stream, with no content. Most annoying!

 

 

Share this post


Link to post
Share on other sites

I followed the method described in the link Pianist's post after I discovered that there is a way to undo any changes (i.e. mistakes) made when doing this process.

 

After a few failing attempts I finally got it right.  This is what worked for me:

 

1) Open a cmd window with admin privileges.

 

2) Use "powercfg -requests" to show the exact name of the device connected wit the audio stream that is preventing sleep:

image.png.4bd0528cb41b46a74c33947f1f823309.png

The name that worked for me was "High Definition Audio Device".

 

3) Use "powercfg -requestsoverride" to tell the SYSTEM that the "High Definition Audio Device" DRIVER should not prevent sleeping:

image.png.2988a1b5e9dcde233c950cc31e32504e.png

Be very careful to get this right as powercfg does not seem to check for valid requests.

 

4) Check that this has been registered OK, use "powercfg -requestoverride" with no parameters:

image.png.4a90ccdb303d8b6efb6d9c14abb70f8b.png

 

And that should do the trick.

 

However, if you screw up, as I did several times, then you can use this undocumented feature of powercfg to remove an entry.  Re-enter the command that you used in step 3) but omit the last parameter - the word SYSTEM.  This is an example of one mistake that I made and how I removed it:

image.thumb.png.5110f140e6692d622cb7e01e2d2fcf2b.png

 

This seems to be working OK for me now and also has the added benefit that Musescore also no longer prevents my computer from going to sleep.

 

Apologies to all who find this too geeky and off-topic, and also apologies for not knowing how to fix this same problem in an iPad.  Thanks to Pianist for pointing me in the right direction.

 

It would be good if the the forum software could be fixed so that it does not turn off Howard's hearing aid.

 

Don.

 

 

Share this post


Link to post
Share on other sites
On 12/6/2019 at 1:52 AM, Don Taylor said:

Roger:...Bookmarking concertina.net should not cause the problem, you need to have it open in a tab. 

Don't know about Chrome as I do not have it installed...

Don, thank you for that clarification - looks like I don't need to do anything.

FWIW, I usually disconnect the Internet when I'm not using it (which is 95% of the time I'm using the computer),

and turn off the computer when I'm not using it.

 

Share this post


Link to post
Share on other sites

I wonder if it's due to the ability of the site to play a sound to tell you that you have a notification. Try clicking on your name at the top right-->account settings-->notification settings (on the right)-->uncheck "Play a sound when I receive a notification" and click "save". 

 

Maybe this will work...

 

Paul

 

Share this post


Link to post
Share on other sites
13 minutes ago, Paul Schwartz said:

I wonder if it's due to the ability of the site to play a sound to tell you that you have a notification. Try clicking on your name at the top right-->account settings-->notification settings (on the right)-->uncheck "Play a sound when I receive a notification" and click "save". 

 

Maybe this will work...

 

Paul

 

Sadly, the audio stream is still in use after changing this setting

Share this post


Link to post
Share on other sites
2 hours ago, Don Taylor said:

Sadly, the audio stream is still in use after changing this setting

 

Oh well. Worth a try.

Actually, did you quit your browser and re-start it (or even re-start your computer to be on the safe side)? I imagine that once the audio playback engine has been instantiated it remains open.

 

 

Share this post


Link to post
Share on other sites

@Don Taylor :

 

Hmmmm, you don't happen to have  someone named Alexa living in your house, do you? ;-)

 

I suspect this third party dreaded ad banner under the top line when you open the forum. I don't like what I see there at all, mostly because it appears to be data mined ads tailored to what someone thinks is my scheme of pray.

 

A geeky thing to do would be to run wireshark and process explorer to see what process actually attempts to establish the internet connection.

 

Share this post


Link to post
Share on other sites

 

On 12/7/2019 at 1:44 PM, Paul Schwartz said:

Actually, did you quit your browser and re-start it (or even re-start your computer to be on the safe side)?

Yes and yes, same result.

8 hours ago, RAc said:

Hmmmm, you don't happen to have  someone named Alexa living in your house, do you? 😉

No, Alexa does not live here.

8 hours ago, RAc said:

A geeky thing to do would be to run wireshark and process explorer to see what process actually attempts to establish the internet connection.

It is not an internet connection but an unwanted audio stream in use that is my problem.  Or was my problem - the fix using powercfg - requestsoverride works for me ... so far.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...